Fabric 실행했을 때 잘 모르겠는 에러가 나면서 cryptography 어쩌고 하면 버전을 체크해보시면 좋겠습니다. 

저같은 경우에는 cryptography 버전이 2.4.2 가 아니면 에러가 나더라고요. 그래서 아래와 같은 명령어로 cryptography 를 다시 설치했습니다. 

 

pip install cryptography==2.4.2

 

pip 설치할 때 패키지명 뒤에 == 를 붙이고 버전을 써주면 해당 버전을 설치해줍니다. 

 

cryptography 버전을 체크하는 방법은 pip freeze를 사용하시면 되는데 pip freeze | grep cryptography 하시면 cryptography 버전만 확인이 가능하죠.

 

아무튼 Fabric 에러나는데 잘 모르겠다. 하시면 cryptography 버전 확인해보세요 :-)

 

 

 

 

 

+ Recent posts